Eroare la WordPress 3.6.1


Atunci când faceți upgrade la versiunea 3.6.1 pentru WordPress puteți da peste următorul mesaj de eroare: „blockUI requires jQuery v1.2.3 or later”.
Dacă pățiți asta, nu dați vina pe WordPress! Unul sau mai multe module, poate chiar tema pe care o folosiți pot fi de vină.

Atunci când acestea verifică ce versiune de jQuery folosiți, compară doar primul digit de după . [punct]. WordPress 3.6 aduce acum versiunea v1.10.2, așa că exista posibilitatea ca mesajul de eroare să fie chiar acesta: „blockUI requires jQuery v1.2.3 or later! You are using v1.10.2”. Pentru noi este evident că v1.10.2 este mai recentă decât v1.2.3, nu și pentru un script făcut pe genunchi.

Soluția problemei nu este aceea de a face downgrade la acel script ci să vedeți care modul este de vină (dezactivându-le pe rând, unul câte unu) și să modificați acea bucățica de script care verifică în mod eronat dacă aveți instalată o versiune nouă de jQuerry.

Consultați discuția de aici pentru mai multe amănunte.

Ai ceva de spus?

Completează mai jos detaliile tale sau dă clic pe un icon pentru a te autentifica:

Logo WordPress.com

Comentezi folosind contul tău WordPress.com. Dezautentificare /  Schimbă )

Fotografie Google

Comentezi folosind contul tău Google. Dezautentificare /  Schimbă )

Poză Twitter

Comentezi folosind contul tău Twitter. Dezautentificare /  Schimbă )

Fotografie Facebook

Comentezi folosind contul tău Facebook. Dezautentificare /  Schimbă )

Conectare la %s

Acest site folosește Akismet pentru a reduce spamul. Află cum sunt procesate datele comentariilor tale.